Application Workspace 4.4.4091 (Major Release)

Application Workspace v4.4.4091 replaces v4.4.4090 in the download portal. This new version resolves an issue with DLL files. 

This Major Version 4.4 release includes new features for Application Workspace, Reporting, and the Application Workspace PowerShell Module.

Application Workspace

UI Rebranding

Application Workspace has a fresh look, with new Recast colours implemented across the UI. As part of our rebranding initiative, we've updated the Launcher icon and the default icon of packages and tags to reflect our new visual identity.

Managed folders (Preview)

A new option lets you enable the managed folders view of applications in the Workspace tab for the end-users. The end-user can then toggle between the tag list and the folder view of applications. (available only if the All filter is selected in the Side menu) For more information, see User Settings, Workspace tab and User Portal.

This feature is currently in preview. We are actively working on enhancing its capabilities and plan to introduce additional functionalities in future updates.

ACME client for Application Workspace Satellite Server

The existing Automated Certificate Management Environment (ACME) client functionality was extended to encompass the Application Workspace Satellite Server. This new feature helps reduce even more the end-user disruption because of expired certificates and decreases the administrative workload of your IT department. At this moment, only “Let’s Encrypt” and "Google Trust Services" are supported. For more information, see Settings.


Known Issue: The Satellite Server UI may become unresponsive if the ACME Settings are misconfigured



The satellite server user interface may become unresponsive or fail when invalid or broken inputs are entered on the Settings page during ACME configuration.

Symptoms

• Error dialogs appear during or after configuration.
• Login functionality stops working after the user logs out.
• In severe cases, the satellite UI becomes inaccessible.

Root Cause

This issue occurs when certain input values are entered in the ACME settings, which can corrupt configuration files and impact the satellite’s ability to interact with its database.

Impact

• Users may be unable to log back in after logging out.
• The satellite server may require a full reinstallation, including its database.

Resolution

Report this issue to Support immediately for assistance.
 Include the following details in your report:

• Steps taken before the issue occurred.
• Screenshots of error dialogs.
• Any relevant logs from the satellite server.


NOTE: Do not attempt manual fixes unless instructed by Support, as this may worsen the problem.

Auditing events on zone level

Events that take place on a zone level are now also displayed in the Auditing screen of Application Workspace.

Microsoft store connector out of preview mode

The preview phase for the Microsoft Store connector has ended. It is now fully supported and available for all users.

Successful status codes defined for MSI, MSU and MSP

In the MSI, MSU and MSP package actions, you now have the possibility to configure successful status codes for the install. For more information, see Install MSI, Install MSP, Install MSU, Install uploaded MSP.

Environment variables

  • Append/unset entries to environment variable array
    In the Set environment variable type of action, you can now append one or more entries to the variable as a suffix when your variable is an array. And in the Unset environment variable type of action, you can unset one or more entries from the variable when your variable is an array.

  • Environment variable separator option
     In the Environment variable value filter, you now have the option to add a separator used in a concatenated environment variable, so that you can ensure these are parsed correctly.

Agent debug mode now available on UI also

The log level of the Application Workspace Agent can now also be set in Application Workspace, in the Agent settings screen.

Offline mode notification

Application Workspace Launcher now displays a banner whenever it goes into offline mode.

Near Realtime Reporting Data

As an alternative to our current Reporting functionality, we now offer you a new Power BI template, hosted externally and not yet integrated into the Application Workspace. This currently provides access only to event data. The new Power BI template expands on the previous reporting feature by offering enhanced granularity and broader data coverage, including insights into licensing, deployments, launch health, install health and much more. For more information, see Reporting.

Application Workspace PowerShell Module

  • The Get-LiquitEvent now also allows you to specify a date range for which you want to retrieve events.
  • Context filters can now also be created through the Application Workspace PowerShell Module.
  • The Get-LiquitAuditingEvent now also retrieves events that take place on the zone level.

Support lifecycle

Application Workspace 4.1 has reached end-of-life.